読者です 読者をやめる 読者になる 読者になる

僕の好きなコードの書き方

Java

僕は「パッと見て何をしてるかが伝わってくるコード」が好きです。なので「名前重要」。

DDDとかじゃなくて、TransactionScript前提で話をしますが。

手続きの中から、意味のある塊を見つけて、それに名前をつけてメソッド化してあげる感じ。

メソッドのサイズは縦横: 30行x120文字くらいがいっかな。僕の頭はそれくらいのメモリしかないし。

1つのメソッドが1つの役割を持つのがいっかな。でも、あんまり深く入っていかないで欲しい。僕の頭はスタックが3つくらいしかないし。

切ったメソッドのスコープはdefault scopeでいっかなと。テストしやすいし。

手続き型で典型的なのはこんな感じかなぁって思いながら書いてみた。何をやってるか伝わってこないよね。書きながら嫌になってた。


僕はこんな風に書くほうが好きです。って書こうとして力尽きました。想像に任せます(え

じゃ、また会おう!

追記

続き書いた。

bufferings.hatenablog.com